const regex = /^[a-z0-9]+[\.a-z0-9]{2,}\@[a-z0-9]{2,}\.[a-z\.]{2,}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-z0-9]+[\\.a-z0-9]{2,}\\@[a-z0-9]{2,}\\.[a-z\\.]{2,}$', 'gm')
const str = `hunganh020301@gmail.com
hung.anh020301@yahoo.com.vn
hunganh@tes.microsoft.com
hunganh 213@gmai l. com
23sneaker.store@shop.vn
h.a.anh @gmail.com
hung. anh
hung .anh
hun.2.3.123`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}