use strict;
my $str = 'hunganh020301@gmail.com
hung.anh020301@yahoo.com.vn
hunganh@tes.microsoft.com
hunganh 213@gmai l. com
23sneaker.store@shop.vn
h.a.anh @gmail.com
hung. anh
hung .anh
hun.2.3.123';
my $regex = qr/^[a-z0-9]+[\.a-z0-9]{2,}\@[a-z0-9]{2,}\.[a-z\.]{2,}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}