#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(["'])(?!\d+\1)[一-龠ぁ-ゔァ-ヴーa-zA-Z0-9々〆〤、。0-9]+\1"
Local $sString = ""文章表示"" & @CRLF & _
""1文章表示"" & @CRLF & _
""文章表示1"" & @CRLF & _
""文章1表示"" & @CRLF & _
""1"" & @CRLF & _
""2345"" & @CRLF & _
""235表""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")