import re
regex = re.compile(r"([\"'])(?!\d+\1)[一-龠ぁ-ゔァ-ヴーa-zA-Z0-9々〆〤、。0-9]+\1", flags=re.MULTILINE)
test_str = ("\"文章表示\"\n"
"\"1文章表示\"\n"
"\"文章表示1\"\n"
"\"文章1表示\"\n"
"\"1\"\n"
"\"2345\"\n"
"\"235表\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")