$re = '/(["\'])(?!\d+\1)[一-龠ぁ-ゔァ-ヴーa-zA-Z0-9々〆〤、。0-9]+\1/m';
$str = '"文章表示"
"1文章表示"
"文章表示1"
"文章1表示"
"1"
"2345"
"235表"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);