using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"VC\[(?!0{5})([0-9]{5})";
string input = @"VC[01234]
VC[012]
VC[00000]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}