const regex = /VC\[(?!0{5})([0-9]{5})/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('VC\\[(?!0{5})([0-9]{5})', 'mg')
const str = `VC[01234]
VC[012]
VC[00000]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}