$re = '/VC\[(?!0{5})([0-9]{5})/m';
$str = 'VC[01234]
VC[012]
VC[00000]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);