#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?six)(?<=ordernr\r|ordernr\n|ordernr\r\n)[^\r\n]+"
Local $sString = " 1. 21Sid1" & @CRLF & _
" 2. Ordernr" & @CRLF & _
" 3. E17222" & @CRLF & _
" 4. By" & @CRLF & _
" 5. Seller"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")