re = /(?<=ordernr\r|ordernr\n|ordernr\r\n)[^\r\n]+/ix
str = ' 1. 21Sid1
2. Ordernr
3. E17222
4. By
5. Seller'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end