const regex = new RegExp('(?<=ordernr\\r|ordernr\\n|ordernr\\r\\n)[^\\r\\n]+', 'gsi')
const str = ` 1. 21Sid1
2. Ordernr
3. E17222
4. By
5. Seller`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}