package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)(\d{3},)(\d{3})(.+?)(([a-zA-Z]{3},)([a-zA-Z]{3}).+)`)
var str = `123,234,345,456,567
abc,bcd,cde,def.`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}