$re = '/(\d{3},)(\d{3})(.+?)(([a-zA-Z]{3},)([a-zA-Z]{3}).+)/s';
$str = '123,234,345,456,567
abc,bcd,cde,def.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);