using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:""(?:[^""]|"")*"")|\S+)";
string input = @"-p ""This is a string ""with quotes"""" d:\1.txt ""d:\some folder\1.out""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}