re = /((?:"(?:[^"]|"")*")|\S+)/
str = '-p "This is a string ""with quotes""" d:\\1.txt "d:\\some folder\\1.out"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end