$re = '/((?:"(?:[^"]|"")*")|\S+)/';
$str = '-p "This is a string ""with quotes""" d:\\1.txt "d:\\some folder\\1.out"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);