#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*\b(HDR(10)?)\b)(?=.*\b(DV|DoVi)\b)"
Local $sString = "# Match" & @CRLF & _
"Movie 2022 IMAX 2160p DSNP WEB-DL TrueHD 7.1 Atmos DoVi HDR HEVC-RlsGrp" & @CRLF & _
"Movie 2022 IMAX 2160p DSNP WEB-DL TrueHD 7.1 Atmos HDR DoVi HEVC-RlsGrp" & @CRLF & _
"Movie 2022 IMAX 2160p DSNP WEB-DL TrueHD 7.1 Atmos HDR10 DoVi HEVC-RlsGrp" & @CRLF & _
"Movie 2022 IMAX 2160p DSNP WEB-DL TrueHD 7.1 Atmos DoVi HDR10 HEVC-RlsGrp" & @CRLF & _
"Movie 2022 IMAX 2160p DSNP WEB-DL TrueHD 7.1 Atmos DV.HDR10 HEVC-RlsGrp" & @CRLF & _
"Movie 2022 IMAX 2160p DSNP WEB-DL TrueHD 7.1 Atmos HDR10.DV HEVC-RlsGrp" & @CRLF & _
"" & @CRLF & _
"# Don't Match" & @CRLF & _
"Movie 2022 IMAX 2160p DSNP WEB-DL TrueHD 7.1 Atmos DV HEVC-RlsGrp" & @CRLF & _
"Movie 2022 IMAX 2160p DSNP WEB-DL TrueHD 7.1 Atmos DoVi HEVC-RlsGrp" & @CRLF & _
"Movie 2022 IMAX 2160p DSNP WEB-DL TrueHD 7.1 Atmos HDR HEVC-RlsGrp" & @CRLF & _
"Movie 2022 IMAX 2160p DSNP WEB-DL TrueHD 7.1 Atmos HDR10 HEVC-RlsGrp"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")