$re = '/^(?=.*\b(HDR(10)?)\b)(?=.*\b(DV|DoVi)\b)/m';
$str = '# Match
Movie 2022 IMAX 2160p DSNP WEB-DL TrueHD 7.1 Atmos DoVi HDR HEVC-RlsGrp
Movie 2022 IMAX 2160p DSNP WEB-DL TrueHD 7.1 Atmos HDR DoVi HEVC-RlsGrp
Movie 2022 IMAX 2160p DSNP WEB-DL TrueHD 7.1 Atmos HDR10 DoVi HEVC-RlsGrp
Movie 2022 IMAX 2160p DSNP WEB-DL TrueHD 7.1 Atmos DoVi HDR10 HEVC-RlsGrp
Movie 2022 IMAX 2160p DSNP WEB-DL TrueHD 7.1 Atmos DV.HDR10 HEVC-RlsGrp
Movie 2022 IMAX 2160p DSNP WEB-DL TrueHD 7.1 Atmos HDR10.DV HEVC-RlsGrp
# Don\'t Match
Movie 2022 IMAX 2160p DSNP WEB-DL TrueHD 7.1 Atmos DV HEVC-RlsGrp
Movie 2022 IMAX 2160p DSNP WEB-DL TrueHD 7.1 Atmos DoVi HEVC-RlsGrp
Movie 2022 IMAX 2160p DSNP WEB-DL TrueHD 7.1 Atmos HDR HEVC-RlsGrp
Movie 2022 IMAX 2160p DSNP WEB-DL TrueHD 7.1 Atmos HDR10 HEVC-RlsGrp';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);