import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*\\b(HDR(10)?)\\b)(?=.*\\b(DV|DoVi)\\b)";
final String string = "# Match\n"
+ "Movie 2022 IMAX 2160p DSNP WEB-DL TrueHD 7.1 Atmos DoVi HDR HEVC-RlsGrp\n"
+ "Movie 2022 IMAX 2160p DSNP WEB-DL TrueHD 7.1 Atmos HDR DoVi HEVC-RlsGrp\n"
+ "Movie 2022 IMAX 2160p DSNP WEB-DL TrueHD 7.1 Atmos HDR10 DoVi HEVC-RlsGrp\n"
+ "Movie 2022 IMAX 2160p DSNP WEB-DL TrueHD 7.1 Atmos DoVi HDR10 HEVC-RlsGrp\n"
+ "Movie 2022 IMAX 2160p DSNP WEB-DL TrueHD 7.1 Atmos DV.HDR10 HEVC-RlsGrp\n"
+ "Movie 2022 IMAX 2160p DSNP WEB-DL TrueHD 7.1 Atmos HDR10.DV HEVC-RlsGrp\n\n"
+ "# Don't Match\n"
+ "Movie 2022 IMAX 2160p DSNP WEB-DL TrueHD 7.1 Atmos DV HEVC-RlsGrp\n"
+ "Movie 2022 IMAX 2160p DSNP WEB-DL TrueHD 7.1 Atmos DoVi HEVC-RlsGrp\n"
+ "Movie 2022 IMAX 2160p DSNP WEB-DL TrueHD 7.1 Atmos HDR HEVC-RlsGrp\n"
+ "Movie 2022 IMAX 2160p DSNP WEB-DL TrueHD 7.1 Atmos HDR10 HEVC-RlsGrp";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}