#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)http(s?://([1-3]\.alph|[45]\.bet)a\.com|(://[67]\.bet|s://6.alph)a\.org)"
Local $sString = "http://1.alpha.com" & @CRLF & _
"http://2.alpha.com" & @CRLF & _
"http://3.alpha.com" & @CRLF & _
"http://4.beta.com" & @CRLF & _
"http://5.beta.com" & @CRLF & _
"http://6.beta.org" & @CRLF & _
"http://7.beta.org" & @CRLF & _
"https://1.alpha.com" & @CRLF & _
"https://2.alpha.com" & @CRLF & _
"https://3.alpha.com" & @CRLF & _
"https://4.beta.com" & @CRLF & _
"https://5.beta.com" & @CRLF & _
"https://6.alpha.org" & @CRLF & _
"" & @CRLF & _
"Should not match:" & @CRLF & _
"" & @CRLF & _
"http://3.alpha.org" & @CRLF & _
"http://6.alpha.org" & @CRLF & _
"https://6.alpha.com" & @CRLF & _
"https://5.alpha.com" & @CRLF & _
"https://5.beta.org" & @CRLF & _
"https://6.beta.org" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")