package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)http(s?://([1-3]\.alph|[45]\.bet)a\.com|(://[67]\.bet|s://6.alph)a\.org)`)
var str = `http://1.alpha.com
http://2.alpha.com
http://3.alpha.com
http://4.beta.com
http://5.beta.com
http://6.beta.org
http://7.beta.org
https://1.alpha.com
https://2.alpha.com
https://3.alpha.com
https://4.beta.com
https://5.beta.com
https://6.alpha.org
Should not match:
http://3.alpha.org
http://6.alpha.org
https://6.alpha.com
https://5.alpha.com
https://5.beta.org
https://6.beta.org
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}