import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "http(s?://([1-3]\\.alph|[45]\\.bet)a\\.com|(://[67]\\.bet|s://6.alph)a\\.org)";
final String string = "http://1.alpha.com\n"
+ "http://2.alpha.com\n"
+ "http://3.alpha.com\n"
+ "http://4.beta.com\n"
+ "http://5.beta.com\n"
+ "http://6.beta.org\n"
+ "http://7.beta.org\n"
+ "https://1.alpha.com\n"
+ "https://2.alpha.com\n"
+ "https://3.alpha.com\n"
+ "https://4.beta.com\n"
+ "https://5.beta.com\n"
+ "https://6.alpha.org\n\n"
+ "Should not match:\n\n"
+ "http://3.alpha.org\n"
+ "http://6.alpha.org\n"
+ "https://6.alpha.com\n"
+ "https://5.alpha.com\n"
+ "https://5.beta.org\n"
+ "https://6.beta.org\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}