re = /if \(\$q->param\('([^']+)'\) =~ m\/([^\/]+)\/\)/
str = 'if ($q->param(\'wordOne[]\') =~ m/wordTwo/)
if ($q->param(\'wordSeventeen[]\') =~ m/anwgknawhknawnhwanh/)'
subst = 'if (grep /\\2/, $q->param(\'\\1\')) { ... }'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result