import Foundation
let pattern = #"if \(\$q->param\('([^']+)'\) =~ m/([^/]+)/\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
if ($q->param('wordOne[]') =~ m/wordTwo/)
if ($q->param('wordSeventeen[]') =~ m/anwgknawhknawnhwanh/)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"if (grep /\2/, $q->param('\1')) { ... }"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)