// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"if \(\$q->param\('([^']+)'\) =~ m/([^/]+)/\)").unwrap();
let string = "if ($q->param('wordOne[]') =~ m/wordTwo/)
if ($q->param('wordSeventeen[]') =~ m/anwgknawhknawnhwanh/)";
let substitution = "if (grep /\\2/, $q->param('\\1')) { ... }";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}