$re = '/^ +/m';
$str = ' this
is
some
content
son
best
believe';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;