#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sm)^@\w+\{.*?^\}"
Local $sString = "@Article{Qin:2013mta," & @CRLF & _
" Title = {{Practical corollaries of transverse Ward-Green-Takahashi identities}}," & @CRLF & _
" Author = {Qin, Si-Xue and Chang, Lei and Liu, Yu-Xin and Roberts, Craig D. and Schmidt, Sebastian M.}," & @CRLF & _
" Journal = {Phys.Lett.}," & @CRLF & _
" Year = {2013}," & @CRLF & _
" Pages = {384-388}," & @CRLF & _
" Volume = {B722}," & @CRLF & _
"" & @CRLF & _
" Archiveprefix = {arXiv}," & @CRLF & _
" Bdsk-url-1 = {http://dx.doi.org/10.1016/j.physletb.2013.04.034}," & @CRLF & _
" Doi = {10.1016/j.physletb.2013.04.034}," & @CRLF & _
" Eprint = {1302.3276}," & @CRLF & _
" Primaryclass = {nucl-th}," & @CRLF & _
" Slaccitation = {%%CITATION = ARXIV:1302.3276;%%}" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"@Article{Qin:2011xq," & @CRLF & _
" Title = {{Investigation of rainbow-ladder truncation for excited and exotic mesons}}," & @CRLF & _
" Author = {Qin, Si-xue and Chang, Lei and Liu, Yu-xin and Roberts, Craig D. and Wilson, David J.}," & @CRLF & _
" Journal = {Phys.Rev.}," & @CRLF & _
" Year = {2012}," & @CRLF & _
" Pages = {035202}," & @CRLF & _
" Volume = {C85}," & @CRLF & _
"" & @CRLF & _
" Archiveprefix = {arXiv}," & @CRLF & _
" Bdsk-url-1 = {http://dx.doi.org/10.1103/PhysRevC.85.035202}," & @CRLF & _
" Doi = {10.1103/PhysRevC.85.035202}," & @CRLF & _
" Eprint = {1109.3459}," & @CRLF & _
" Primaryclass = {nucl-th}," & @CRLF & _
" Slaccitation = {%%CITATION = ARXIV:1109.3459;%%}" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"@Article{Qin:2011dd," & @CRLF & _
" Title = {{Interaction model for the gap equation}}," & @CRLF & _
" Author = {Qin, Si-xue and Chang, Lei and Liu, Yu-xin and Roberts, Craig D. and Wilson, David J.}," & @CRLF & _
" Journal = {Phys.Rev.}," & @CRLF & _
" Year = {2011}," & @CRLF & _
" Pages = {042202}," & @CRLF & _
" Volume = {C84}," & @CRLF & _
"" & @CRLF & _
" Archiveprefix = {arXiv}," & @CRLF & _
" Bdsk-url-1 = {http://dx.doi.org/10.1103/PhysRevC.84.042202}," & @CRLF & _
" Doi = {10.1103/PhysRevC.84.042202}," & @CRLF & _
" Eprint = {1108.0603}," & @CRLF & _
" Primaryclass = {nucl-th}," & @CRLF & _
" Slaccitation = {%%CITATION = ARXIV:1108.0603;%%}" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"@Article{Qin:2013ufa," & @CRLF & _
" Title = {{Quark Spectral Function and Deconfinement at Nonzero Temperature}}," & @CRLF & _
" Author = {Qin, Si-xue and Rischke, Dirk H.}," & @CRLF & _
" Journal = {Phys.Rev.}," & @CRLF & _
" Year = {2013}," & @CRLF & _
" Pages = {056007}," & @CRLF & _
" Volume = {D88}," & @CRLF & _
"" & @CRLF & _
" Archiveprefix = {arXiv}," & @CRLF & _
" Bdsk-url-1 = {http://dx.doi.org/10.1103/PhysRevD.88.056007}," & @CRLF & _
" Doi = {10.1103/PhysRevD.88.056007}," & @CRLF & _
" Eprint = {1304.6547}," & @CRLF & _
" Primaryclass = {nucl-th}," & @CRLF & _
" Slaccitation = {%%CITATION = ARXIV:1304.6547;%%}" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")