import re
regex = re.compile(r"^@\w+\{.*?^\}", flags=re.DOTALL | re.MULTILINE)
test_str = ("@Article{Qin:2013mta,\n"
" Title = {{Practical corollaries of transverse Ward-Green-Takahashi identities}},\n"
" Author = {Qin, Si-Xue and Chang, Lei and Liu, Yu-Xin and Roberts, Craig D. and Schmidt, Sebastian M.},\n"
" Journal = {Phys.Lett.},\n"
" Year = {2013},\n"
" Pages = {384-388},\n"
" Volume = {B722},\n\n"
" Archiveprefix = {arXiv},\n"
" Bdsk-url-1 = {http://dx.doi.org/10.1016/j.physletb.2013.04.034},\n"
" Doi = {10.1016/j.physletb.2013.04.034},\n"
" Eprint = {1302.3276},\n"
" Primaryclass = {nucl-th},\n"
" Slaccitation = {%%CITATION = ARXIV:1302.3276;%%}\n"
"}\n\n"
"@Article{Qin:2011xq,\n"
" Title = {{Investigation of rainbow-ladder truncation for excited and exotic mesons}},\n"
" Author = {Qin, Si-xue and Chang, Lei and Liu, Yu-xin and Roberts, Craig D. and Wilson, David J.},\n"
" Journal = {Phys.Rev.},\n"
" Year = {2012},\n"
" Pages = {035202},\n"
" Volume = {C85},\n\n"
" Archiveprefix = {arXiv},\n"
" Bdsk-url-1 = {http://dx.doi.org/10.1103/PhysRevC.85.035202},\n"
" Doi = {10.1103/PhysRevC.85.035202},\n"
" Eprint = {1109.3459},\n"
" Primaryclass = {nucl-th},\n"
" Slaccitation = {%%CITATION = ARXIV:1109.3459;%%}\n"
"}\n\n"
"@Article{Qin:2011dd,\n"
" Title = {{Interaction model for the gap equation}},\n"
" Author = {Qin, Si-xue and Chang, Lei and Liu, Yu-xin and Roberts, Craig D. and Wilson, David J.},\n"
" Journal = {Phys.Rev.},\n"
" Year = {2011},\n"
" Pages = {042202},\n"
" Volume = {C84},\n\n"
" Archiveprefix = {arXiv},\n"
" Bdsk-url-1 = {http://dx.doi.org/10.1103/PhysRevC.84.042202},\n"
" Doi = {10.1103/PhysRevC.84.042202},\n"
" Eprint = {1108.0603},\n"
" Primaryclass = {nucl-th},\n"
" Slaccitation = {%%CITATION = ARXIV:1108.0603;%%}\n"
"}\n\n"
"@Article{Qin:2013ufa,\n"
" Title = {{Quark Spectral Function and Deconfinement at Nonzero Temperature}},\n"
" Author = {Qin, Si-xue and Rischke, Dirk H.},\n"
" Journal = {Phys.Rev.},\n"
" Year = {2013},\n"
" Pages = {056007},\n"
" Volume = {D88},\n\n"
" Archiveprefix = {arXiv},\n"
" Bdsk-url-1 = {http://dx.doi.org/10.1103/PhysRevD.88.056007},\n"
" Doi = {10.1103/PhysRevD.88.056007},\n"
" Eprint = {1304.6547},\n"
" Primaryclass = {nucl-th},\n"
" Slaccitation = {%%CITATION = ARXIV:1304.6547;%%}\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")