// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?sm)^@\w+\{.*?^\}").unwrap();
let string = "@Article{Qin:2013mta,
Title = {{Practical corollaries of transverse Ward-Green-Takahashi identities}},
Author = {Qin, Si-Xue and Chang, Lei and Liu, Yu-Xin and Roberts, Craig D. and Schmidt, Sebastian M.},
Journal = {Phys.Lett.},
Year = {2013},
Pages = {384-388},
Volume = {B722},
Archiveprefix = {arXiv},
Bdsk-url-1 = {http://dx.doi.org/10.1016/j.physletb.2013.04.034},
Doi = {10.1016/j.physletb.2013.04.034},
Eprint = {1302.3276},
Primaryclass = {nucl-th},
Slaccitation = {%%CITATION = ARXIV:1302.3276;%%}
}
@Article{Qin:2011xq,
Title = {{Investigation of rainbow-ladder truncation for excited and exotic mesons}},
Author = {Qin, Si-xue and Chang, Lei and Liu, Yu-xin and Roberts, Craig D. and Wilson, David J.},
Journal = {Phys.Rev.},
Year = {2012},
Pages = {035202},
Volume = {C85},
Archiveprefix = {arXiv},
Bdsk-url-1 = {http://dx.doi.org/10.1103/PhysRevC.85.035202},
Doi = {10.1103/PhysRevC.85.035202},
Eprint = {1109.3459},
Primaryclass = {nucl-th},
Slaccitation = {%%CITATION = ARXIV:1109.3459;%%}
}
@Article{Qin:2011dd,
Title = {{Interaction model for the gap equation}},
Author = {Qin, Si-xue and Chang, Lei and Liu, Yu-xin and Roberts, Craig D. and Wilson, David J.},
Journal = {Phys.Rev.},
Year = {2011},
Pages = {042202},
Volume = {C84},
Archiveprefix = {arXiv},
Bdsk-url-1 = {http://dx.doi.org/10.1103/PhysRevC.84.042202},
Doi = {10.1103/PhysRevC.84.042202},
Eprint = {1108.0603},
Primaryclass = {nucl-th},
Slaccitation = {%%CITATION = ARXIV:1108.0603;%%}
}
@Article{Qin:2013ufa,
Title = {{Quark Spectral Function and Deconfinement at Nonzero Temperature}},
Author = {Qin, Si-xue and Rischke, Dirk H.},
Journal = {Phys.Rev.},
Year = {2013},
Pages = {056007},
Volume = {D88},
Archiveprefix = {arXiv},
Bdsk-url-1 = {http://dx.doi.org/10.1103/PhysRevD.88.056007},
Doi = {10.1103/PhysRevD.88.056007},
Eprint = {1304.6547},
Primaryclass = {nucl-th},
Slaccitation = {%%CITATION = ARXIV:1304.6547;%%}
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}