re = /((<(.)*\\>)|( |\t)|(\n))*/
str = '<p\\> <p\\>
<br \\> <br\\>
<teste \\>
<\\ 123>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end