import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Test(\\s(\\d+(\\.\\d+)?|[a-z]))?$";
final String string = "Test 1\n"
+ "Test 123\n"
+ "Test 1.1\n"
+ "Test\n"
+ "Test a\n"
+ "Test 1a";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}