const regex = new RegExp('^Test(\\s(\\d+(\\.\\d+)?|[a-z]))?$', 'gm')
const str = `Test 1
Test 123
Test 1.1
Test
Test a
Test 1a`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}