import re
regex = re.compile(r"^Test(\s(\d+(\.\d+)?|[a-z]))?$", flags=re.MULTILINE)
test_str = ("Test 1\n"
"Test 123\n"
"Test 1.1\n"
"Test\n"
"Test a\n"
"Test 1a")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")