#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(<p value="id">(?=1445).+\R.+<p value="IP">)(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})(.+)"
Local $sString = " <list name="ItemList">" & @CRLF & _
" <item>" & @CRLF & _
" <p value="id">1445</p>" & @CRLF & _
" <p value="IP">10.25.30.19</p>" & @CRLF & _
" <p value="Prflen">26</p>" & @CRLF & _
" </item>" & @CRLF & _
" <list name="ItemList">" & @CRLF & _
" <item>" & @CRLF & _
" <p value="id">1499</p>" & @CRLF & _
" <p value="IP">10.40.50.53</p>" & @CRLF & _
" <p value="Prflen">26</p>" & @CRLF & _
" </item>" & @CRLF & _
" <list name="ItemList">" & @CRLF & _
" <item>" & @CRLF & _
" <p value="id">1445</p>" & @CRLF & _
" <p value="IP">10.45.70.19</p>" & @CRLF & _
" <p value="Prflen">26</p>" & @CRLF & _
" </item>" & @CRLF & _
" <list name="ItemList">" & @CRLF & _
" <item>" & @CRLF & _
" <p value="id">1446</p>" & @CRLF & _
" <p value="IP">10.77.90.55</p>" & @CRLF & _
" <p value="Prflen">26</p>" & @CRLF & _
" </item>"
Local $sSubst = "\110.25.30.19\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)