# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<p value=\"id\">(?=1445).+\R.+<p value=\"IP\">)(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})(.+)"
test_str = (" <list name=\"ItemList\">\n"
" <item>\n"
" <p value=\"id\">1445</p>\n"
" <p value=\"IP\">10.25.30.19</p>\n"
" <p value=\"Prflen\">26</p>\n"
" </item>\n"
" <list name=\"ItemList\">\n"
" <item>\n"
" <p value=\"id\">1499</p>\n"
" <p value=\"IP\">10.40.50.53</p>\n"
" <p value=\"Prflen\">26</p>\n"
" </item>\n"
" <list name=\"ItemList\">\n"
" <item>\n"
" <p value=\"id\">1445</p>\n"
" <p value=\"IP\">10.45.70.19</p>\n"
" <p value=\"Prflen\">26</p>\n"
" </item>\n"
" <list name=\"ItemList\">\n"
" <item>\n"
" <p value=\"id\">1446</p>\n"
" <p value=\"IP\">10.77.90.55</p>\n"
" <p value=\"Prflen\">26</p>\n"
" </item>")
subst = "\\110.25.30.19\\3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.