#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?is)^http:\/\/.*-[A-HJ-NPR-Z\d]{17}$"
Local $sString = "http://www.mbwhiteplains.com/new/2015/mercedes/c250/2015-mercedes-c250-red-white-plains-for-sale-wddgj4hb9fg356378" & @CRLF & _
"" & @CRLF & _
"http://www.mbwhiteplains.com/new/2015/mercedes/gla250/2015-mercedes-gla250-silver-white-plains-for-sale-wdctg4gb0fj034301" & @CRLF & _
"" & @CRLF & _
"http://www.mbwhiteplains.com/new/2015/mercedes/gla250/2015-mercedes-gla250-red-white-plains-for-sale-wdctg4gb2fj039824" & @CRLF & _
"" & @CRLF & _
"http://www.mbwhiteplains.com/used/2014/mercedes/c300/2014-mercedes-c300-grey-white-plains-for-sale-wddgf8ab9er323919" & @CRLF & _
"" & @CRLF & _
"http://www.mercedesbenzofeaston.com/used/2014/mercedes/c300/2014-mercedes-c300-white-columbus-for-sale-wddgf8ab6er324414"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")