import re
regex = re.compile(r"^http:\/\/.*-[A-HJ-NPR-Z\d]{17}$", flags=re.IGNORECASE | re.DOTALL)
test_str = ("http://www.mbwhiteplains.com/new/2015/mercedes/c250/2015-mercedes-c250-red-white-plains-for-sale-wddgj4hb9fg356378\n\n"
"http://www.mbwhiteplains.com/new/2015/mercedes/gla250/2015-mercedes-gla250-silver-white-plains-for-sale-wdctg4gb0fj034301\n\n"
"http://www.mbwhiteplains.com/new/2015/mercedes/gla250/2015-mercedes-gla250-red-white-plains-for-sale-wdctg4gb2fj039824\n\n"
"http://www.mbwhiteplains.com/used/2014/mercedes/c300/2014-mercedes-c300-grey-white-plains-for-sale-wddgf8ab9er323919\n\n"
"http://www.mercedesbenzofeaston.com/used/2014/mercedes/c300/2014-mercedes-c300-white-columbus-for-sale-wddgf8ab6er324414")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")