package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?is)^http:\/\/.*-[A-HJ-NPR-Z\d]{17}$`)
var str = `http://www.mbwhiteplains.com/new/2015/mercedes/c250/2015-mercedes-c250-red-white-plains-for-sale-wddgj4hb9fg356378
http://www.mbwhiteplains.com/new/2015/mercedes/gla250/2015-mercedes-gla250-silver-white-plains-for-sale-wdctg4gb0fj034301
http://www.mbwhiteplains.com/new/2015/mercedes/gla250/2015-mercedes-gla250-red-white-plains-for-sale-wdctg4gb2fj039824
http://www.mbwhiteplains.com/used/2014/mercedes/c300/2014-mercedes-c300-grey-white-plains-for-sale-wddgf8ab9er323919
http://www.mercedesbenzofeaston.com/used/2014/mercedes/c300/2014-mercedes-c300-white-columbus-for-sale-wddgf8ab6er324414`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}