$re = '/(\w+=\'\')\ /';
$str = '<h1 class=\'\' id=\'\' title=\'\'></h1>';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;