#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\$.*LOB.*00 &$"
Local $sString = "$90TM020516 19002200&" & @CRLF & _
"$90LOB 0 0 0 7 10 &" & @CRLF & _
"$90LOB 25 0 0 6 10 &" & @CRLF & _
"$90LOB 57 0 0 6 10 &" & @CRLF & _
"$90LOB353 0 0 5 10 &" & @CRLF & _
"$90LOB 36 0 0 5 10 &" & @CRLF & _
"$90GPSA8 0 38281168 -77448376&" & @CRLF & _
"$90LOB276 0 0 5 10 &" & @CRLF & _
"$90LOB185 0 0 6 10 &" & @CRLF & _
"$90LOB197 0 0 6 00 &" & @CRLF & _
"$90LOB198 0 254 6 00 &" & @CRLF & _
"$90LOB197 0 254 6 00 &" & @CRLF & _
"RSSI $90LOB201 0 254 5 00 &" & @CRLF & _
"$90TM020516 19002300&" & @CRLF & _
"$90LOB194 0 254 5 00 &" & @CRLF & _
"$90LOB190 0 254 5 00 &" & @CRLF & _
"$90LOB185 0 254 5 00 &" & @CRLF & _
"$90LOB181 0 254 5 00 &" & @CRLF & _
"$90LOB187 0 254 5 00 &" & @CRLF & _
"$90LOB192 0 254 5 00 &" & @CRLF & _
"$90LOB195 0 254 5 00 &" & @CRLF & _
"$90LOB195 0 254 5 00 &" & @CRLF & _
"$90LOB191 0 254 5 00 &" & @CRLF & _
"$90LOB184 0 254 5 00 &" & @CRLF & _
"$90LOB177 0 254 5 00 &"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")