# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\$.*LOB.*00 &$"
test_str = ("$90TM020516 19002200&\n"
"$90LOB 0 0 0 7 10 &\n"
"$90LOB 25 0 0 6 10 &\n"
"$90LOB 57 0 0 6 10 &\n"
"$90LOB353 0 0 5 10 &\n"
"$90LOB 36 0 0 5 10 &\n"
"$90GPSA8 0 38281168 -77448376&\n"
"$90LOB276 0 0 5 10 &\n"
"$90LOB185 0 0 6 10 &\n"
"$90LOB197 0 0 6 00 &\n"
"$90LOB198 0 254 6 00 &\n"
"$90LOB197 0 254 6 00 &\n"
"RSSI $90LOB201 0 254 5 00 &\n"
"$90TM020516 19002300&\n"
"$90LOB194 0 254 5 00 &\n"
"$90LOB190 0 254 5 00 &\n"
"$90LOB185 0 254 5 00 &\n"
"$90LOB181 0 254 5 00 &\n"
"$90LOB187 0 254 5 00 &\n"
"$90LOB192 0 254 5 00 &\n"
"$90LOB195 0 254 5 00 &\n"
"$90LOB195 0 254 5 00 &\n"
"$90LOB191 0 254 5 00 &\n"
"$90LOB184 0 254 5 00 &\n"
"$90LOB177 0 254 5 00 &")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.