using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\$.*LOB.*00 &$";
string input = @"$90TM020516 19002200&
$90LOB 0 0 0 7 10 &
$90LOB 25 0 0 6 10 &
$90LOB 57 0 0 6 10 &
$90LOB353 0 0 5 10 &
$90LOB 36 0 0 5 10 &
$90GPSA8 0 38281168 -77448376&
$90LOB276 0 0 5 10 &
$90LOB185 0 0 6 10 &
$90LOB197 0 0 6 00 &
$90LOB198 0 254 6 00 &
$90LOB197 0 254 6 00 &
RSSI $90LOB201 0 254 5 00 &
$90TM020516 19002300&
$90LOB194 0 254 5 00 &
$90LOB190 0 254 5 00 &
$90LOB185 0 254 5 00 &
$90LOB181 0 254 5 00 &
$90LOB187 0 254 5 00 &
$90LOB192 0 254 5 00 &
$90LOB195 0 254 5 00 &
$90LOB195 0 254 5 00 &
$90LOB191 0 254 5 00 &
$90LOB184 0 254 5 00 &
$90LOB177 0 254 5 00 &";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}