import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([0]?[1-9]|1[0-2])\\/([0-2]?[0-9]|3[0-1])\\/[1-2]\\d{3}) (20|21|22|23|[0-1]?\\d{1}):([0-5]?\\d{1}):([0-5]?\\d{1})$";
final String string = "12/12/2006 00:00:00";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}