const regex = /^(([0]?[1-9]|1[0-2])\/([0-2]?[0-9]|3[0-1])\/[1-2]\d{3}) (20|21|22|23|[0-1]?\d{1}):([0-5]?\d{1}):([0-5]?\d{1})$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(([0]?[1-9]|1[0-2])\\\/([0-2]?[0-9]|3[0-1])\\\/[1-2]\\d{3}) (20|21|22|23|[0-1]?\\d{1}):([0-5]?\\d{1}):([0-5]?\\d{1})$', '')
const str = `12/12/2006 00:00:00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}