re = /(?:^|(\w)(?!\1))(([A-Z])\3{3})(?!\3)/m
str = '3346AAAA44
3973BBBBBB44
9755BBBBBBAAAA44
AAAAB
AAAA
BAAAA
AAAAA'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end