$re = '/<span>\D+(\d+)\D+<\/span>/';
$str = '<span>Abc456ABC</span>
<span>Abcdef789ABCgh</span>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);