// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<span>\D+(\d+)\D+<\/span>").unwrap();
let string = "<span>Abc456ABC</span>
<span>Abcdef789ABCgh</span>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}