re = /<span>\D+(\d+)\D+<\/span>/
str = '<span>Abc456ABC</span>
<span>Abcdef789ABCgh</span>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end