const regex = /\b[^.,]+\./g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[^.,]+\\.', 'g')
const str = `item.i_item_sk,item.i_item_id,item.i_rec_start_date,item.i_rec_end_date`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}