$re = '/\b[^.,]+\./';
$str = 'item.i_item_sk,item.i_item_id,item.i_rec_start_date,item.i_rec_end_date';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);